• homepost1

  • homepost4

  • homepost2

  • homepost5

  • homepost3

  • homepost6

  • homepost7

Instalando metasploit no Ubuntu

O Metasploit Framework é bem suportado na plataforma Ubuntu. As instruções a seguir devem ser igualmente aplicáveis para Kubuntu, Xubuntu, e Debian.

Dependências:

 
Instale as dependências do Ruby:
$ sudo apt-get install ruby libopenssl-ruby libyaml-ruby libdl-ruby libiconv-ruby libreadline-ruby irb ri rubygems

Instale o cliente do Subversion:
$ sudo apt-get install subversion

Para construir as extensões nativas (pcaprub, lorcon2, etc), os seguintes pacotes precisam ser instalados:
$ sudo apt-get build-dep ruby
$ sudo apt-get install ruby-dev libpcap-dev

Suporte de banco de dados

A fim de usar a funcionalidade de banco de dados, RubyGems junto com os drivers apropriados devem estar instalados:
Postgres é o banco de dados recomendado:
$ sudo apt-get install postgresql-8.4
$ sudo apt-get install rubygems libpq-dev
$ sudo gem install pg

Ou para o MySQL:
$ sudo apt-get install mysql-server
$ sudo apt-get install rubygems libmysqlclient-dev
$ sudo gem install mysql

Sqlite irá trabalhar para tarefas básicas, mas não é mais suportado!
$ sudo apt-get install sqlite3
$ sudo apt-get install rubygems libsqlite3-dev
$ sudo gem install sqlite3-ruby

Consulte as instruções do banco de dados de configuração(abaixo), quando você tiver concluído a instalação.

Framework


Uma vez que a dependência tenha sido instalado, baixe o Metasploit para Linux da página de download(http://www.metasploit.com/framework/download/) e execute os seguintes comandos:

$ tar xf framework-3.X.tar.gz
$ sudo mkdir -p /opt/metasploit3
$ sudo cp -a msf3/ /opt/metasploit3/msf3
$ sudo chown root:root -R /opt/metasploit3/msf3
$ sudo ln -sf /opt/metasploit3/msf3/msf* /usr/local/bin/

Ou:
$ sudo su
# chmod +x framework-3.X.X-linux-XXXX.run
# ./framework-3.X.X-linux-XXXX.run

Extensões


O quadro inclui algumas extensões nativas Ruby que deve ser compilado para usar certos tipos de módulos.
Para ativar o módulo socket: 

$ sudo apt-get install libpcap-dev
$ sudo bash
# cd /opt/metasploit3/msf3/external/pcaprub/
# ruby extconf.rb
# make && make install

Para habilitar os módulos Wi-Fi:
$ sudo bash
# cd  /opt/metasploit3/msf3/external/ruby-lorcon2/
# svn co https://802.11ninja.net/svn/lorcon/trunk lorcon2
# cd lorcon2
# ./configure --prefix=/usr && make && make install
# cd ..
# ruby extconf.rb
# make && make install

Atualizações


O Metasploit Framework é atualizado diariamente com os últimos exploits, , payloads, features(recursos) e correções de bugs. Para atualizar a instalação do framework:
$ sudo svn update /opt/metasploit3/msf3/

Isso também pode ser instalado em crontab do usuário root:
$ sudo crontab -e -u root # inserar a linha abaixo
 1 * * * * /usr/bin/svn update  /opt/metasploit3/msf3/ >> /var/log/msfupdate.log 2>&1



Ref: http://www.metasploit.com

Filed Under: ,

About the Author

My name is Dinh Quang Huy or known as alias NhamNgaHanh .I made this template in magazine style and named it Simplex Darkness .I hope it helpful to persons who want a solutions for a template in Blogspot.To download this template and see template install instruction ,go to Simplex Design blog.

1 comment

Trackback URL | Comments RSS Feed

  1. Bhior says:

    Que bom que pensa assim, ao contrario de alguns, não e isso que acontece.

    Abraços

     

Leave a Reply